S3
MinIO
登录后可跨设备保存划线和私人笔记登录
在 MinIO 上创建目录
在基于 MinIO 存储创建目录时,重要的是要将 endpoint 属性配置为指向你自己的 MinIO 集群。如果未设置 endpoint 属性,Polaris 将尝试连接 AWS 存储服务(在这种情况下必然会失败)。
注意:MinIO 不要求设置 region,但本示例中为了简化说明仍进行了设置,因为 AWS SDK(Polaris 内部使用)通常需要该设置。也可以在 Polaris 服务器进程的 AWS_REGION 环境变量中设置区域,从而无需将 region 作为目录属性进行设置。
注意:下例中的名称 quickstart_catalog 在其他快速入门示例中会被引用,当然,它可以是任何有效的目录名称。
CLIENT_ID=root
CLIENT_SECRET=s3cr3t
DEFAULT_BASE_LOCATION=s3://example-bucket/my_data
REGION=us-west-2
polaris \
--client-id ${CLIENT_ID} \
--client-secret ${CLIENT_SECRET} \
catalogs \
create \
--storage-type s3 \
--endpoint http://127.0.0.1:9100
--default-base-location ${DEFAULT_BASE_LOCATION} \
--region ${REGION} \
quickstart_catalog在更复杂的部署中,可能需要为 S3 请求和 STS(AssumeRole)请求配置不同的端点。这可以通过 --sts-endpoint CLI 选项来实现。
此外,如果 Polaris Server 自身需要使用的 S3 端点与客户端 / 引擎使用的端点不同,可以使用 --endpoint-internal CLI 选项来设置 Polaris Server 使用的 S3 端点。
Polaris 源代码的 getting-started/minio 模块中提供了一个可用于 docker-compose 的 MinIO 示例。
评论
登录后参与评论
正在加载评论…
KnowForge